在安装BookStack时遇到的composer问题

最近一直想弄一个好点的markdown的文档系统来管理知识,找到了两个:

  1. wiki.js node.js 写的非常好看;
  2. 一个是php 写的BookStack;

为了更低的维护成本,加上咱们是曾经是PHP的信徒。

  1. 使用git clone 下载相关包;

2. 使用lnmp 在服务器上创建相关的站点;

3. 使用composer install –no-dev 进行安装包的时候遇到错误,在安装BookStack的过程当中遇到了一个问题:

Your lock file does not contain a compatible set of packages. Please run composer update.

Problem 1
– Root composer.json requires PHP extension ext-fileinfo * but it is missing from your system. Install or enable PHP’s fileinfo extension.
Problem 2
– intervention/image is locked to version 2.6.1 and an update of this package was not requested.
– intervention/image 2.6.1 requires ext-fileinfo * -> it is missing from your system. Install or enable PHP’s fileinfo extension.
Problem 3
– league/flysystem is locked to version 1.1.4 and an update of this package was not requested.
– league/flysystem 1.1.4 requires ext-fileinfo * -> it is missing from your system. Install or enable PHP’s fileinfo extension.
Problem 4
– league/mime-type-detection is locked to version 1.7.0 and an update of this package was not requested.
– league/mime-type-detection 1.7.0 requires ext-fileinfo * -> it is missing from your system. Install or enable PHP’s fileinfo extension.
Problem 5
– league/flysystem 1.1.4 requires ext-fileinfo * -> it is missing from your system. Install or enable PHP’s fileinfo extension.
– league/flysystem-aws-s3-v3 1.0.29 requires league/flysystem ^1.0.40 -> satisfiable by league/flysystem[1.1.4].
– league/flysystem-aws-s3-v3 is locked to version 1.0.29 and an update of this package was not requested.

To enable extensions, verify that they are enabled in your .ini files:
– /usr/local/php/etc/php.ini
You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

想办法解决,看来是ext-fileinfo的问题;

处理思路:

  1. 下载php安装包;
  2. 进入到ext 的fileinfo目录;
  3. 使用phpize 安装;

搞定,问题解决。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注